CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on I am DONE with map making. (On Hold for Now)

    In reply to DrSuperEvil:

    Quote from DrSuperEvil >>

    Digital depreciation is a well known issue among digital media. Hollywood has even admitted that it was better to store celluloid movies than going digital due to the frequency of format updates needed.

     

    The last major map breaking changes happened during HOTS while the new patch changes only affect trigger loops.

     Yeah, and since so many people are telling me that Blizzard is going to fix the issues soon, I'm not going to be done with it... For now. I'll wait and see what happens first! :)
    Posted in: General Chat
  • 0

    posted a message on I am DONE with map making. (On Hold for Now)

    In reply to EDHRIANO:

    Quote from EDHRIANO >>

    Why not just roll back your version of the editor to earlier version before the patch ?

     Well.... If this changes are going to be kept by Blizzard, I see no point of going back since if I do that - the map will be "Single-Player Only." But thanks for the suggestion!
    Posted in: General Chat
  • 0

    posted a message on I am DONE with map making. (On Hold for Now)

    In reply to TChosenOne:

    Quote from TChosenOne >>

    Shame to see you go.  I loved the viacre ch.2 as a concept, and the map you were making was a great improvement upon it.

     Thank you. I spent 2~3 years on it, so it was improved for sure... Although it's broken now. So, I will go for now. But if there by any chance the editor's 4.0 issues ... Get's *fixed* once again, I will return. But for now, I'm gone. Thanks for the testing the other day!
    Posted in: General Chat
  • 0

    posted a message on Patch 4.0 Sudden Errors [Partially SOLVED]

    In reply to Zolden:

    Quote from Zolden >>
    That's why I announced to others out there that I'm DONE with map making. The errors are continuing... Without reason.
     
     Don't panic, dude, we can fix this shit.
     Hmmmm... Let's hope so. Although I can't seem to fix this for now, I will have a glimmer of hope then. Thanks!
    Posted in: Triggers
  • 0

    posted a message on Patch 4.0 Sudden Errors [Partially SOLVED]

    In reply to Zolden:

    Quote from Zolden >>

    Yea, describe please your solutions for the 4.0 related trigger fuckups.

     As I said above, there were unseen errors with the "Pick Each Unit" and "Pick Each Player" Triggers. For example, the editor allowed the trigger to be like this:

    Pick each unit in [HEROES] Group
    - Do Something for Picked Integer
    - Do Something for Picked Player
    - Do Something for Picked SOMETHING OTHER THAN UNITS
    But now, the editor sees what's going on with this and makes you fix this by:
    Pick each unit in [HEROES] Group
    - Do Something for Picked Unit
    - Do Something for Picked Unit
    - Do Something for Picked Unit
    BUT. The only errors that were fixed was this "Picked" triggers. For others, its.... not working for me as well. That's why I announced to others out there that I'm DONE with map making. The errors are continuing... Without reason.
    Posted in: Triggers
  • 0

    posted a message on I am DONE with map making. (On Hold for Now)

    Hello SC2Mapster. You guys were my guardian angels from beginning to end - by always giving me the answers that I needed. But now.... I don't think that's going to happen anymore.

     

    You see - with every SC2's major patch, my maps were broken. I was in my elementary school/middle school when these patches occurred, so I was able to fix them up using my time. Hours and hours and hours. But now... I'm not a kid anymore so I can't invest that much time into my broken map.

    After I fixed the trigger errors that occurred this patch - I went and tested my map. But... The map wouldn't even start anymore.

    So as always, I tried everything I could - removing triggers / modifying triggers / and did many experiments. But then I came to one single conclusion.

     

    There was no reason for this error. The error was simple. The editor wasn't loading half of the triggers in the map without any reason. I tested this by setting up the trigger with no conditions. The trigger was about:


    "Start Cinematic mode"

    "Stop Cinematic mode"

    "Load Bank"

    "Display Text Message"

     

    And there were no conditions in any of it. They worked just fine the previous patch. And now... They don't. Only "Start Cinematic Mode" works now. The rest didn't work. With no reason - as there were no "If then Else" triggers / and no conditions. They should have worked perfectly. But they won't work. If this was a complicated trigger or had conditions and such I would have thought differently, but no. This was an extremely simple trigger.

    So... I'm DONE. I'm fed up with Blizzard's "EDITOR IMPROVEMENTS" that F$*^&$ up my maps EVERY SINGLE TIME.

     

    It's going to be more worth it to develop games with Unity/Unreal or just... Anything other than SC2. As they don't break.

     

    Thank you all in SC2Mapster who helped me throughout the madness of fixing - and I hope you guys wouldn't experience something like this. Good luck with your development!

    Posted in: General Chat
  • 0

    posted a message on Patch 4.0 Sudden Errors [Partially SOLVED]

    In reply to DrSuperEvil:

    Quote from DrSuperEvil >>

    So what was the cause/solution?

    Well... The cause was "Skip Remaining Actions" Trigger was considered the same thing as "x2 Returns." So removing "Skip Remaining Actions" triggers solved the issue.

     

    Also, there were errors in the "Pick Each" triggers that the previous Editor ignored - but they are now being addressed properly. So all I had to do was fix them up by giving those triggers proper values and such.
    Posted in: Triggers
  • 0

    posted a message on Patch 4.0 Sudden Errors [Partially SOLVED]

    Thank you everyone who helped me to maintain my sanity throughout this *adventure.* I was able to fix this by correcting every "PICK EACH" triggers in the Editor.

    Posted in: Triggers
  • 0

    posted a message on Patch 4.0 Sudden Errors [Partially SOLVED]
    Quote from hjfabre >>
    Quote from hjfabre >>
    Quote from hjfabre >>

    Hello again, SC2Mapster's Triggers Section!

     

    I was really happy to see SC2 having a big, big patch that optimized (somehow?) SC2 - but it broke my map. As with every other big SC2 patch. However, unlike the errors of "Yesterday," this time the error seems so.... Vague. I can't seem to find what error is causing me to not be able to publish my map. Can anyone see an error here? Because for such a simple trigger, I'm not seeing it.

     

    *Check the photo*

     

    Thanks in advance!

     Thank you SC2Mapster's Discord for quickly answering my question! But now one more error remains - and this seems a bit more difficult. Can anyone see what's wrong with the trigger here? *Check the Photo*
     But once again, thanks to Talv in SC2Mapster's Discord this was fixed! Now there's another problem. What could be wrong here?
     Thank you Talv so much for your continuous answers! But once again, another problem struck me. This time, there was a "Pick Each Player" Trigger right above it, but this one still says something is wrong. So I added more and more "Pick Each Player" Triggers - and resulted in even more errors. What could be wrong here?
    Posted in: Triggers
  • 0

    posted a message on Patch 4.0 Sudden Errors [Partially SOLVED]
    Quote from hjfabre >>
    Quote from hjfabre >>

    Hello again, SC2Mapster's Triggers Section!

     

    I was really happy to see SC2 having a big, big patch that optimized (somehow?) SC2 - but it broke my map. As with every other big SC2 patch. However, unlike the errors of "Yesterday," this time the error seems so.... Vague. I can't seem to find what error is causing me to not be able to publish my map. Can anyone see an error here? Because for such a simple trigger, I'm not seeing it.

     

    *Check the photo*

     

    Thanks in advance!

     Thank you SC2Mapster's Discord for quickly answering my question! But now one more error remains - and this seems a bit more difficult. Can anyone see what's wrong with the trigger here? *Check the Photo*
     But once again, thanks to Talv in SC2Mapster's Discord this was fixed! Now there's another problem. What could be wrong here?
    Posted in: Triggers
  • 0

    posted a message on Patch 4.0 Sudden Errors [Partially SOLVED]
    Quote from hjfabre >>

    Hello again, SC2Mapster's Triggers Section!

     

    I was really happy to see SC2 having a big, big patch that optimized (somehow?) SC2 - but it broke my map. As with every other big SC2 patch. However, unlike the errors of "Yesterday," this time the error seems so.... Vague. I can't seem to find what error is causing me to not be able to publish my map. Can anyone see an error here? Because for such a simple trigger, I'm not seeing it.

     

    *Check the photo*

     

    Thanks in advance!

     Thank you SC2Mapster's Discord for quickly answering my question! But now one more error remains - and this seems a bit more difficult. Can anyone see what's wrong with the trigger here? *Check the Photo*
    Posted in: Triggers
  • 0

    posted a message on Patch 4.0 Sudden Errors [Partially SOLVED]

    Hello again, SC2Mapster's Triggers Section!

     

    I was really happy to see SC2 having a big, big patch that optimized (somehow?) SC2 - but it broke my map. As with every other big SC2 patch. However, unlike the errors of "Yesterday," this time the error seems so.... Vague. I can't seem to find what error is causing me to not be able to publish my map. Can anyone see an error here? Because for such a simple trigger, I'm not seeing it.

     

    *Check the photo*

     

    Thanks in advance!

    Posted in: Triggers
  • 0

    posted a message on Error: Moonwalking

    In reply to DrSuperEvil:

    Quote from DrSuperEvil >>

    Then after the skin swap you probably need to recreate the Turret actor on the actor for the unit.

     Yeah I kind of predicted that answer might come after I saw different turrets being used by the Titanic Warp Prism and the normal Warp Prism. I guess your answer confirmed my suspicions. Thanks for the rescue yet again, Dr. Super Evil!
    Posted in: Data
  • 0

    posted a message on Error: Moonwalking

    In reply to DrSuperEvil:

    Quote from DrSuperEvil >>

    Does the unit itself have a turret?

     As it is basically a duplication of the Warp Prism, everything except the fact that it is a ground unit and having weapons is the same = which means yes, it does have a turret for it to rotate in the Phasing mode.
    Posted in: Data
  • 0

    posted a message on Error: Moonwalking

    In reply to DrSuperEvil:

    Quote from DrSuperEvil >>

    Open the models in the cutscenes editor and check for a TurretZ attachment point. Under the Units data type is the Combat: Weapons - Turret field and there is a type of actor called Turret which needs to be recreated under some circumstances (usually one of the top five events of a Unit type actor creates one).

     

    So you saying your custom model has a hardcoded rotation speed? Tried using a SOp(Smooth Rotation) SOp?

     Thanks for the answer once again! Hmmm.....  I'll check the SOp of the actor. And the turret can be found in the Cutscene Editor I see. And no, it is not a custom model - its actually the "Nerazim Warp Prism" model. As I mentioned previously, using the normal Warp Prism Model works fine - the error only occurs when I change the unit's model to "Nerazim Warp Prism" made by Blizzard Entertainment.
    Posted in: Data
  • To post a comment, please or register a new account.