• 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    1. Noted

    2. Going to be looking into this again soon.

    I am a bit late today. Very busy day. Hopefully not to let for a few questions. Here are my questions for today.

     

    3. How to turn attached models to face the direction that its host model moves slowly.

    Kind of in a way like colossi turn their heads slowly when selecting a different location to turn. You can see in the picture what I would like to do. The host model, I also want to figet facing different randomized directions within a 135 degrees of the direction its facing or so. 

     

    *Also. Thought it would be worth mentioning that when I started trying that advice you have me to how to have weapons shoot from attachment points on attached models it started working for just about every single weapon I've tried it on just perfectly. For some reason it is not working right in that one specific situation which is why I will need to check everything meticulously to see if I can find out something wrong with it first.

    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    In reply to DrSuperEvil:

    1. Yes. I tried this again, but this time adding an axis tweak a tiny a bit and it worked perfectly.

    2. Understanding X,Y,Z.

    So that is what those fields do. That makes things somewhat more clear. Something I am not clear on though is how I would understand what directions points such and such a direction in relation to the model to start with. I was having a look at models for rotation specs. I see a blue, green and red circle in the field for rotation. Which x,y and z planes do these colors represent for one thing? Maybe I am going about understanding this the wrong way.

    3 and 4.[Solved]

    For now I don't really have any other questions. I am mostly trying to get a number of special composite units with attachments done. Today I am going to be seeing if I can understand how texture changing is done. I am also having some trouble with this other unit.

    This unit requires some work with explicit rotations since I am trying to get the top of the docking bay model facing forward. I've already asked about explicit rotations of course. If you have any other information that you think could help me get this figured out, that would be great. 

     

    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

     

    In reply to DrSuperEvil:

    1. Alright.
    If this is a rare problem, then I guess a different choice of model shouldn't be much an issue. I am sure I can figure out a good replacement for that one.
    2. [Solved]
    I remember said that and I knew it was going to become an issue soon or later, but I just was not quite clear when. What do up vectors do once again? Now that I've seen how important they are in situations like this.
    3. The first 1 and 2 checks are done. The last one I will be trying soon. 
    3.1. What I mean by that is that hosted model says in a completely fixed position while the hosting model will move and fidget without moving the hosted model with it. If this does require a reference set of actions to re-establish the host subject, I am will need some explanation on how this is done since I have not done this before myself.
    4. How to get structures to move?
    One new question I have for today is about making movable structure. I tried setting the acceleration to 1000 and movement speed of one structure to 3. It did not move. The structure that I was trying to get moving for starters was a command center. I am assuming there is probably something in flags that needs to be toggled which I am not aware of or maybe some sort of ability needed or required to remove. Not sure about this.
    EDIT:
    Update: The Rotator trick worked for 1 and 3 and just about every model so far that has been having this issue. Turns out all I needed to do was make one small weak rotator and it started fixing the problem with no issues.
    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    In reply to DrSuperEvil:

    1. So I gather this. To prevent that issue from happening, the model needs to be force updated somehow without it being affected in a bad way. Maybe there is a work around in such situation in which the 0 speed rotation method won't work? There is a number of other models I am having similar issues with, but I've yet to try the zero rotation trick. I think you mentioned some sort of method about that in one of the messages you sent me.

    5. Alright. Its seems to be working now.

    2. Purifier Mothership Attached to dragoon flipping upside down randomly

    The unit below I called an Interstellar World Purifier. I have a purifier mothership from the warchest attached to the Hammer107's Purifier Eradas Dragoon as seen here:

    This is how it is supposed to look like. The moment that the dragoon hosting it starts working, here is what happens:

    It flips upside down. Now here is a picture of the SOPs that I am using. Both of them are default and core.

    Those are on the model actor that creators the mothership. The dragoon does the walking.

    This shows the dragon's attachment points. You'll notice that the attachment point for weapon points backwards. That is why I used sop90 to have it face up.

    3. Certain units' attached models won't follow them when morphing.

    Right here I have what I call a shadow host. I attached some thorns to the weapon03 attachment weapon of the host model to give it a more menacing look. When it burrows, the model will not follow it into burrowing though. While it stands still, the model also doesn't follow it either. When I tried this with the exact same model, same attachment point, but used a spore crawler instead, it worked perfectly. I wonder why its not working with this model right. More importantly, what can be done to fix this? Also there aren't any other Sops used along with this. Just Sopattachweapon03. This is also happening with lots of other models. I figure once I learn how to get it this one fixed, I will be able to solve the others.

     

    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    In reply to DrSuperEvil:

    1. When you say 0 speed, are you talking about Basic: Actor: Rate?

    4. I think I will stick to a more simple model then with the head as the unit and multiple doom crawlers following behind at different scales. One thing I should point out is that as I am using the Protoss snake unit for something else, I am trying to recreate a new version of this unit which makes things somewhat more complicated. 

    5. How would I go about setting delay for .05? Is this done via timers?

     

    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    In reply to DrSuperEvil:

    There was an operation called SOPattachharness listed under that section, but upon removing it, nothing changed. One simple thing I think could be done is to use a local offset for the launch point, but the thing is that I need to learn how this is done so I can apply it to other situations as well as what is going wrong here. I am going to do some trial and error and examine everything meticulously to see if I can find anything that might be keeping this from working properly. The setup that you explain feels like it should be working.
    3. Sure thing
    While walking it looks relatively how it is supposed to.
    When standing still, this is how it what happens as it fights. the carrier models stay locked in place. Good idea in regards to the normal immortal. I do want to learn though how to fix this since there may be many other situations in which I won't have such an alternative.
    3. Very helpful. I will keep note of this and the linked page I added to my favorites.
    4. How to create a chained caterpillar like unit?
    I had this cool idea for something called the Doom catacrawler based based off hammer 107s doom crawler model. I basically want to create a boss unit with, the head of a tempest, several body segments as doom crawlers that follow behind with each segment being an individual unit and a void ray as a tail. Now I was having a look at the Protoss snake demo, but the Protoss snake demo has a tail body that moves in a wavy faction. I simply want each segment to follow the head with a small increment. Here is another sonic boss as an example. Kinda like this, but without the jumping.
    And I will also want it to shoot ranged weapons instead. As for the void ray tail. I am going to decide what to with that later, but I already know how to make the weapons.
    5. How to properly attach models to other attached models?
    Ever since you've taught me how to attach units to other models I've been having a ball creating lots of new units for many of the factions in this mod and one of the things I am trying to do is understand how to attach units to other attached units to create some very interesting constructs. Here is an example:
    This here is a mothership attached to a wrath walker and I attempted to attach a few slayn missile turrets to them by stating that the slaym missile turrets are created on birth of the wrath walker, but using an sop attachment specifically stating the subject as the mothership. What I would like to know is how I would have them attached to the mothership instead if that is possible. When I tried actor creation, nothing happened.
    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    1. Still not working yet, but I have a few possible ideas why.

    First off. Here is a few pictures of important things:

    The model I want to shoot from with attachment points:

    The events used to attempt creating the site actor listed on the model actor.

    Table view of the action actor that is used for the weapon that this unit is meant to launch.

    A picture of the site actor I am using from table view. It uses the core sopattachhead.

    My primary suspicion is that I did not set up the events to create the site actor properly, since I was not positive in what manner I should set them up. I also had at one point tried using Actor Creation>Create Site Test. Site Test is the name of the site actor that I am using. The other thing I wonder about is if the two attachment points that have been set under the action actor and the site actor are canceling out each other. I also wonder if I need to create a custom sop attachment instead of using the core sop head attachment. 

     

    2. Re: Carrier Vanguard

    It does persist when walking. Despite this, I tried that rotator suggestion you had. This had no effect. One thing also is that when I tried something like this with a regular immortal, but I was using the Protoss docking bay as launch guns for the arms instead this did not happen. Of course, I would like to learn how to do this with the models in the picture. So far, this is what it looks like:

     

    3. More information about rotation specs.

    I basically wanted more information about these fields.

    Specifically what I am confused about is how the forward and up fields affect rotation. Like for example. Lets say I wanted to tilt a mothership 90 degrees to the left or right, which field would one use to affect these? I've been doing some trial and error, but it is kinda trick cause I don't know exactly what I am doing. My aim is to understand how in particular the up and forward fields change angle of a unit.

    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    In reply to DrSuperEvil:

     1. More details
    Can you be more specific about the steps involved? After the attempt I made nothing happened, but I was not quite sure where to input the site actor under the action actor and I was not sure if I was supposed to directly link the site actor to the attached model or if it needed something else.
    2. Very helpful!
    This worked almost perfectly. Right now the carrier models are attached as they should be and this also helped me resolve a number of other similar issues. I was also noticing the other sop attach core actors. I will keep note of those. Now the problem that still remains though is that for whatever reason the carrier models aren't following the vanguard as it moves its weapon guns and changes motion as it stands. It will be within range though. In the cutscene editor, those attachment points for the weapons on the vanguard are shown to be moving as it fights and generally just does most animations. Do you have an ideas what can be done to get it in sync here?
    3.1-3.2 Still working on this one.
    This should be interesting when its done!
     
    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    In reply to DrSuperEvil:

    Alright. Once I come back to that data issue I am gonna try that. The lack of the create persistent seems to be why it did not work right. Here are my next questions for today:
    1. How to set a weapon to attack from an attachment point on an attached model?
    I soon realized that you can't just simply set the action actor to the attachment point on an attached model and expect it to work alone. There must be something else that needs to be done for this to work. I am just not sure what.
    2. Issues with the weapon attachment points
    I am trying to attach Tal'darim Carriers to the weapons here on this vanguard to make a new unit. Now there is 2 problems. The first problem is that the Tal'darim Carrier Models aren't moving alongside the weapon attachment points. Second is this:
    I have double checked that both SOPs for each Tal'darim carrier model are set to the subject being this new unit created and both attachment queries are set to weapon 0 and weapon1. Well I mean one is and the other is weapon01. I wondered if you might have an idea for how to fix this or have an idea of what I might be doing wrong here? Maybe there is something under the SOP attachments that needed adjusting. One more thing to know is that this new unit is copied from the vanguard.
    3.1 How to have rotation change periodically?
    I am trying to do something like the boss at 5:13 in this video where there is a number of rotating units spiraling around a host unit that change periodically change rotation for a cool effect. I think I remember how to make a unit orbit around another. What about periodically changing its orbit though like in the video?
    3.2 Doing Damage
    I think I asked this a while ago, but I might be able to better understand now. How would I be able to get the spinning models to deal damage as they spin?
    Posted in: Data
  • 0

    posted a message on A number of questions about complicated issues that I need some help with. [Project Critical/FinalTouches]

    In reply to DrSuperEvil:

    Its working perfectly now! The turret is turning and animating as the weapon shoots follows the unit properly! I have just one question for today. Its about dealing with forces.
    1. How to get a unit to be pushed back when hit with a missile?
    For a certain unit, I simply want to give it the ability to push back units when it attacks with missiles. Upon the missile impacting is when I want the unit to be pushed back. I think I asked this question a lot while ago. Since I am more knowledgable about missiles now, I might be able to understand it this time around.
    Posted in: Data
  • 0

    posted a message on A number of questions about Trigger related issues

    In reply to DrSuperEvil:

    Going to recap in a few days as I try to figure this out. Also trying to get a set of units and abilities done now that I know how to get those overhanging panels working.
    Posted in: Triggers
  • 0

    posted a message on A number of questions about Trigger related issues

    In reply to DrSuperEvil:

    Ah. No wonder it wasn't working. I feel like such a noob right now. Reminds me of back when I was still trying to get a basic understanding of how morphing animation a structure to another structure with animations worked. You remember that topic about the Amon hkdralisk den? Took me months to finally really understand how to properly and finally be able to get that working properly on my own. So one step at a time. However its not working perfectly quite just yet. How do I hide the default ui again since I want to replace this new ui with the old one? Maybe I missed something. 
    Posted in: Triggers
  • 0

    posted a message on A number of questions about Trigger related issues

    5. What am I doing wrong here?

    Something is wrong with the Imgur servers at the time so I input an attached picture below. That is my basic question for today. I used the same set of actions as with the call down panels except with the new actors and I changed mainframe to gameui. However I was noticing that there is still the portrait part to check. I did not change anything with that because I did not see a portrait under gameui. Maybe I missed it. Should I remove the portrait selection from game ui?

    Note: Ignore the last 5 actions in the highlighted section. That was for something else.

    Posted in: Triggers
  • 0

    posted a message on A number of questions about Trigger related issues

    1. Alright. Well, I've come this far. Maybe I eventually might be able to figure how that is done. Although I cannot thank you enough. With so many of the limited resources outside of Sc2mapster, I don't think I would have been able to get this far with your valuable advice. Certainly would have taken much longer.

    2. Simple question. How does one hide dialog's without hiding buttons?

    I probably should already know this. Maybe I have just forgotten how this is done. There is a number of buttons that I want to have visible on the screen, but with no dialog visible. Unless there is a way of setting up buttons without a dialog? Might be harder anyway.

    3. Elaboration on the GameUI layout?

    Is this the part that you were talking about? I tried inputting GameUI as the frame in place of the location where Mainframe will located and soaoverlaytemplate as the portrait. Since I am a noob at this, it is still hard for me to understand exactly what stuff it is that makes things work, but I am getting a clearer idea. Commandpanel was left the same. When I tried this, nothing showed up different. I used the same setup that you were using from the demo. Before I tried this, I simply tried switching the model with one of the console his and it showed up. Could it be possible it is not showing up due to offsets or something like that? 

    4. Image of Buttons is not showing up. What could I have done right?

    Okay. I got the caster units in place and the buttons although they are working and I understand now how to offset them, the image of the buttons is not showing up. I looks like I copy and pasted most of the stuff needed for them to show up, but its the images that aren't showing up. Maybe I should study this a bit more carefully. I must have missed something.

    Posted in: Triggers
  • 0

    posted a message on A number of questions about Trigger related issues

    In reply to DrSuperEvil:

     Here is another quick question. I am about to get started on these others today, but as I was working on 2, I noticed another potential issue:
    1. How to position buttons behind tentacles, but remain in front of the panel?
    In co-op, many buttons are able to hide behind certain parts of tentacles or parts of the panel. Maybe this is actually simple and has to do with setting render priority. Just wanted to check in case it is something more complex?
    Posted in: Triggers
  • To post a comment, please or register a new account.