CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Standard Melee Guidelines?
    Quote from Xenostalker: Go

    I was working on a melee guide but lost interest very quickly due to my current custom map in development.

    I have attached what I completed as well as two reference pictures.

    If anyone wants to complete it, or if a group wants to add on bits to it over time, permission is granted. I just couldn't come to put these three items into the recycling bin :(

    -Xeno

    This is good stuff. You shoudl go on with it. Please analyze a TPW map :) Tehre is one error though, 1v1 arrengement 12 isnt viable. You cant spawn short close positions.

    Posted in: Melee Development
  • 0

    posted a message on Patch 1.2.1 PTR

    Who published theese maps on EU? I noticed there was a strange and hard AI. Is that used by bliz on the testserver, or is it somehting that guy added?

    Posted in: General Chat
  • 0

    posted a message on [Co-op Campaign]Shadow of the Xel'Naga

    I'd like to test too, but can't find the map on EU when I search for "Shadow of" or the full name

    Posted in: Project Workplace
  • 0

    posted a message on [Data] Trigger-free Leap

    @Rhadamant5186: Go

    How do you mean? And why woudln't it work?

    I use this with the changes ProciacMule suggested and it works, although it looks like sh*t, but that it did before the patch also. (the unit missile is extremely glitchy)

    Posted in: Tutorials
  • 0

    posted a message on [Video] Diablo Camera & Movement

    I've been looking for a better solution to this.

    In the upcoming 1.2 patch it is stated that this will change in the editor:

    "New trigger event: Mouse Moved, sent in response to the mouse being moved in the game world. "

    Will this change anything?

    Preliminary changes are listed here : http://us.battle.net/sc2/en/forum/topic/1213111662

    Edit: The patch is released and someone said the way to check mouse position is an event. Some said this was yay, other's theat they rather had a function.

    Still like to revive this topic .. is there a better solution out there now?

    Posted in: Tutorials
  • 0

    posted a message on [Trigger, Data] - Set camera to follow unit perfectly, no portrait 'bug'

    Is it possible to disable the portrait part of the interface, or is the command card, portrait, etc one huge UI element?

    BTW, the answer to the question in my last post seems to be yes - at least two players over bnet can share the same camera object with the trigger I made. I don't know if they get one instance of the object each, or if the camera is taking turns (every 0.1 second) to display for both players. Either way, the visual result is the same. I attached the same region to two player units in a similar fashion, but not every 0.1 second as in the trigger above - which leads me to believe that my first guess is correct (an instance of an object is created for both players, at least cameras that follows and attached regions).

    Posted in: Tutorials
  • 0

    posted a message on ZHRPG Data now public

    Thanks, gonna check it out. The map is published on EU too?

    I noticed a gameplay video with low graphic settings and a dull and slow boss fight ... no abilities were used. Not trying to be rude, only helpful - you might want a better vid out for promoting it.

    I can see you have a high q website up and a growing community with lots of ppl posting on various topics. Thats wonderful. Keep going strong :)

    Update: Can't find ZH RPG or zerg hunt RPG or similar on bnet EU :(

    Posted in: Tutorials
  • 0

    posted a message on [Tutorial] Creating a SC2 Mod File for Custom Data Edits

    Ok, a reinstall of the game fixed the unit model issue.

    About mod publishing, I havnt tried it out, but the editor says that you must have a valid published file as dependency if you want to pulbish a map with that dependency. In other words, you publish the mod seperately. I havn't tried it out and havn't noticed any mod on bnet.

    Posted in: Tutorials
  • 0

    posted a message on [Tutorial] Creating a SC2 Mod File for Custom Data Edits

    from teh campaign definitely. You see how my triggers look like in the working version of my map I attached in the last post. I'll investigate further on mod dependency then.

    EDIT:

    Dude ... unit models in the terrain editorn are f*cked up even in other maps that has nothign to do with themod attempt. The other problem I had, with triggers disappearing, might have everythign to do with me adding the mod to the original map. I did change folder structure in the Maps/ folder where I keep my maps.. but that shoudln't affect anything. Could it be that I added a mod to the Mod/ folder .. and that somehow screwed up the other dependencies?

    Edit2:

    In addition to the white eggs on some random units (or all units) in the editor only, the goliath and Tosh model lacks textures. It has nothing to do with the actor. I'll reisntall the game later to see if this fixes the problem.

    Posted in: Tutorials
  • 0

    posted a message on [Tutorial] Creating a SC2 Mod File for Custom Data Edits

    Ok, cool. What about the triggers in the library that you noticed?

    About the tutorial in generl, I see a downside on using this if you want to pulbish to battle.net, unless custom dependencies/mods are supported (are baked in when publishing). I will investigate that with a copy of my map, if you havn't?

    Posted in: Tutorials
  • 0

    posted a message on [Tutorial] Creating a SC2 Mod File for Custom Data Edits

    I believed I created the mod the way you described, why I was so surprised that the original map file was affected. I did all the swapping and coppying of files (xml and localization txt) via the windows explorer. The only thing I believe I made different from your OP guide was to save the XML files into the wrong data folder.

    I also saved the CL in the same folder as the original .sc2map file. Not 100% sure but I think so.

    I MIGHT have overwriten the map file with the component list version of it, at some point .. since they look the same when opening and saving using the editor explorer. I did use different names for them though.

    I MIGHT have had the component list file, or the component list folder, or mod file open in the editor at the same time.

    This is what I did after following the steps in the tutorial:

    • removed the CL folders for both the mod and the map.
    • opened my original .sc2map and got a shitload of error messages (I didn't save those and don't know what they meant). My custom units lacked models (egg-like model displayed instead, just like when you have a unit with no actor applied to it, although the actors were).
    • pressed 'V' to turn Lock to game view settings off. I have placement grid displayed but instead of showing green and red layers over the terrain all was purple.
    • I played the map and all seemed to be fien in-game. Triggers were functionen, data was and the terrrain/units looked fine.
    • I tried to fix by adding the mod as a dependency. I saved the map and opened it again. They terrain now looked fine. I checked the Triggers and the editor started to validate them. This took some time and when it was done I got a bunch of warning messages that all triggers had duplicates ( This is strange, since the mod shoudln't transfer triggers over? ).
    • I removed the duplicates or original triggers so that I had only one set of triggers. I saved the map and re-opnened. Now all triggers were gone.
    • I removed the mod from dependencies and adding it back a coupple of times. Nothing changed.
    • I made a new empty trigger and saved the map. Before ssave was compelted, the editor crashed. Reprorate 100%. As a sidenote, the editor creates a folder named Ghast_Prototype_Core_Alpha.SC2Map.temp when saving. This is normal? It looks just like the Component List.

    The crash log gives me no clue. If you want to see it, just repro this point.

    • opening the map (mod dependencies removed) the white eggs appear for different unit models every time, not just my custom models. Only unit models, though, and still no problem in-game.

    ------

    I have a backup from 2 days ago, with most data and triggers the same. I just did a lot in the terrain editor (which I consider placeholders anyways) so it's not a big deal. Do you think I should copy the terrain (units, doodads. etc) from my broken map to my backup, or will that break my backup too, do you think? I could try but not realize if it's broken at once, I supose.

    ------

    I'm looking at the original map, the oen that is broken. I cant find my triggers in the library - the folders I see is Built-in and Liberty. Thats the library, right? I'll give you my non-broken backup file from two days ago, so that you can see what triggers I use. I could quite easily recreate what I've done with the triggers, so don't bother for my sake.

    Posted in: Tutorials
  • 0

    posted a message on [Tutorial] Creating a SC2 Mod File for Custom Data Edits

    Thank you for checking it out. I might have reversed the process out of confusion. Sounds strange, though, that I would copy to the map when the process was about copying from the CL to the mod.

    I can't fix it then, beacuse I deleted the CL and mod (folders) at the point the .sc2mod file was finnished.

    Edit: I got the latest working version of the map published, though. Do you know where published maps are saved locally and if it's possible to make a normal map fiel out of them? I'ts locked by publish settings, but I've heard that maps are not truly locked?

    Posted in: Tutorials
  • 0

    posted a message on [Tutorial] Creating a SC2 Mod File for Custom Data Edits

    It seems that there are bugs in the editor, yes.

    My problem is now this:

    I added my .sc2mod to the dependencies of my original .sc2map to try to fix the map again. It seemed to fix the terrain bugs, however when I checked on the triggers they all had duplications with the same names. I recieved a lot of warnig messages form the editor. I removed the duplicates (or perhaps I remeoved the originals) and then saved the map.

    I then opened the map again and checked the trigger editor. All triggers where gone, not just the duplicates. I wonder if there is a way to get the triggers back from the .sc2mod? I've tried to add the mod to dependecies, again, but the triggers in the mod doesn't apply. I also tried creating a blank map and adding the mod, but no triggers from the mod appeared.

    Now, I can't even add new triggers to the map or copy-paste from an old backup. If I do and save the map, the editor crashes.

    So, do you know of a way to get the triggers from the .sc2mod back? I tried saving the mod into a CL folder. There is a TriggerStrings.txt in the localizedData folder .. but that's all I can see.

    Edit: added files, so that you can see for yourself

    Posted in: Tutorials
  • 0

    posted a message on [Tutorial] Creating a SC2 Mod File for Custom Data Edits

    see my edit of my first post, thanks

    Edit: I read, and that was the expected answers, I supose .. thinking of the mapfile as an archive helps a lot. Also, I noticed windows consider the mod file to be a folder (cat).

    If the .mod and -sc2map are both undependent of the CL, how could saving the map as CL s* up the original for me?

    about your answer to the first question.. please clarify. I put all the XML files in the enUS.SC2Data folder. Is that worng or doesn't the folder structure matter?

    Edit 2: it seems adding my mod to the dependencies fixed the visual errors in the terrain editor, at least, so I supose I succeeded with the mod. But now my map is dependent on the mod? Gotta check if bnet play is broken

    Posted in: Tutorials
  • 0

    posted a message on [Tutorial] Creating a SC2 Mod File for Custom Data Edits

    Thanks, a couple of questions though.

    1. In point 6 - to what folder do I paste the xml files? YOu say 'copy to your Component List'. Is that the root folder of the mod, or the enGB.SC2Data folder within? I am guessing the Data folder.

    2. at 7 there is GameStrings.txt in the target folder. I supose I should overwrite that one?

    3. do you know if I must publish the mod file to bnet as well, or will it be included in the map I publish, using the mod?

    4. Can I delete the Component List folder for the Component List I created in #1 when all is done. I am asuming I need none of the folders when the final mod file is created, since it contains all data. Correct?

    5. It would be helpful to understand what a Component List is compared to a mod. Could you explain that further?

    EDIT:

    DONT DO THIS if you don't know what you're doing! IT MAY BREAK YOUR MAP FILE!

    Make a backup of your mapfile first. I didnt think saving the map as a component list wouldnt affect the original SC2Map file so didnt make a backup - but it did. It seems it makes your orignal map dependent on the Component List when you save it as... ?

    There are no visible errors in the gameplay (when testing), or the data editor, only the terrain editor - the custom units I've made and placed out in the terrain are lacking their model in the editor.

    I got several errors messages about stuff being removed, when I first opened the map. Not usre what else is missing atm...

    Posted in: Tutorials
  • To post a comment, please or register a new account.