CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Moving Control Group Panel

    @IrkumeeLegion: Go

    it doesn't know what you mean with relative="ControlPanel". and since it doesn't know it can't place it on the screen. use $parent or $parent/$parent, or some reference like $parent/InfoPanel

    Posted in: UI Development
  • 0

    posted a message on UI Errors, Bugs and Fixes

    @Dragoneles: Go

    that error is because creation of a frame of that type is not allowed by non-blizzard maps.
    if you wrongly reference an existing frame then you can also get that message because the game thinks you want to create a new frame of that type.

    I will add this to the list above when I have more time.

    Posted in: UI Development
  • 0

    posted a message on [BUG] Show Game UI won't work after hidden 2x+ in a row

    show/hide game UI stores the game UI state at the moment of hiding, so if you hide it twice it is stored as hidden instead of leaving it as it is, Show game UI doesn't work then anymore. Going into cinematic mode also calls this trigger, so if your UI is hidden when cinematic mode starts then it loses the correct hiding settings.

    Best fix is to create an action definition which sets the needed frames to show upon calling it. Also don't forget to reset the screenmode if needed.

    below is the Show/Hide game UI action definition as it is shown in the trigger editor:

    Show/Hide Game UI
        Options: Action
        Return Type: (None)
        Parameters
            Show/Hide = Hide <Show/Hide Option>
            Players = (All players) <Player Group>
        Grammar Text: Show/Hide game UI for Players
        Hint Text: Shows or hides the entire game UI.
        Custom Script Code
        Local Variables
            Player = 0 <Integer>
            UIFrame = Menu Bar <UI Frame Type>
        Actions
            General - If (Conditions) then do (Actions) else do (Actions)
                If
                    Show/Hide == Show
                Then
                    Player Group - For each player Player in Players do (Actions)
                        Actions
                            General - If (Conditions) then do (Actions) else do (Actions)
                                If
                                    (Player Player is in cinematic mode) == False
                                    (Player Player is in story mode) == False
                                Then
                                    UI - Set screen mode to Normal for (Player group(Player)) over Immediate seconds
                                Else
                    UI - Restore game UI for Players
                Else
                    Player Group - For each player Player in Players do (Actions)
                        Actions
                            General - If (Conditions) then do (Actions) else do (Actions)
                                If
                                    (Player Player is in cinematic mode) == False
                                    (Player Player is in story mode) == False
                                Then
                                    UI - Set screen mode to Fullscreen for (Player group(Player)) over Immediate seconds
                                Else
                    UI - Store game UI for Players
                    UI - For each UI frame UIFrame
                        Actions
                            General - If (Conditions) then do (Actions) else do (Actions)
                                If
                                    Or
                                        Conditions
                                            (Map is Blizzard) == True
                                            UIFrame != Battle UI
                                Then
                                    UI - Hide UIFrame for Players
                                Else
    
    Posted in: Galaxy Editor Bugs and Feedback
  • 0

    posted a message on UI Layout - Need help

    @Fullachain: Go

    • you should be able to, as I mentioned earlier I do not know which frame it is exactly.
    • at the inventory panel, did you set the offset of this anchor to a negative or positive value? if positive make it negative :)
    <Frame type="Frame" name="ContainerSizeFrame">               
            	<Anchor side="Top" relative="$parent/Button00" pos="Min" offset="..."/>               
            	....
    
    Posted in: UI Development
  • 0

    posted a message on UI Layout - Need help

    @Fullachain: Go

    ow and you can remove quite a bit of the code at the commandpanel. It might be that my changes there also affected the mouseover, I'll add those adjustments here in a moment.

    Edit:

    This is the settings I used for the test for the commanpanel:

      	<Frame type="CommandPanel" name="GameUI/UIContainer/ConsoleUIContainer/CommandPanel" file="GameUI">
        		<Anchor side="Left" relative="$parent" pos="Min" offset="0"/>
           		<Anchor side="Right" relative="$parent" pos="Max" offset="0"/>
           		<Anchor side="Bottom" relative="$parent" pos="Max" offset="-150"/>
           		<Width val="380"/>
           		<Height val="80"/>
    	</Frame>
    
    Posted in: UI Development
  • 0

    posted a message on Show us your cool custom UI-s!

    Hmmm wonder how mine looks ;p

    Posted in: UI Development
  • 0

    posted a message on UI Layout - Need help

    @Fullachain: Go

    the problem lies with the last frame definition (inside the inventory panel):

          	<Frame type="Frame" name="ContainerSizeFrame">               
            	<Anchor side="Top" relative="$parent/Button00" pos="Min" offset="-180"/>               
            	<Anchor side="Bottom" relative="$parent/Button00" pos="Max" offset="20"/>               
            	<Anchor side="Left" relative="$parent/Button00" pos="Min" offset="-20"/>
            	<Anchor side="Right" relative="$parent/Button05" pos="Max" offset="20"/>
          	</Frame>
    

    the problem is the one that is not 20 or -20. it causes an overlap with the commandpanel and catches the mouseclicks that are intended for the commandpanel.

    Posted in: UI Development
  • 0

    posted a message on UI Layout - Need help

    @Fullachain: Go

    1. the tooltips should still appear at their old location, unless you changed that. It is another frame, don't know which one right away.

    2. that is the battlenet friends button background that you see there.

    Posted in: UI Development
  • 0

    posted a message on UI Layout - Need help

    @Fullachain: Go

    Here are the problems you are running into with why it does it like that:
    1. The commandcard is not centered.
    You have set the width of the command card to be 1200, this will result in 600 px from the center to each side.
    The first button of the command card will thus be 600px from the center, and the 5th will be 296px (600-(4*76)) from the center.
    to solve this problem you can just resize the command card with to be the exact size you want it to be by changing the width value

    2. the info panel is anchored in the middle of the screen.
    the anchors are set so that the info panel should appear centered. Change the anchor as followed:
    top anchor: relative $this
    left anchor: relative $this
    bottom anchor: relative $parent
    right anchor: relative $parent

    Hope this helps.

    Posted in: UI Development
  • 0

    posted a message on Looking in Layout..

    @xxxNEARBYxxx: Go

    I think that one is hardcoded. Otherwise it should be listed inside the CommandPanel.

    Posted in: UI Development
  • 0

    posted a message on [Solved] Anchor to top? (different in windowed mode)

    @Hookah604: Go

    I think you can try to anchor it the menubar. the anchor name for it is: "$parent/$parent/FullscreenUpperContainer/MenuBar" if I'm correct.
    hope this helps.

    Posted in: UI Development
  • 0

    posted a message on [Solved] Anchor to top? (different in windowed mode)

    @Hookah604: Go

    Can you perhaps add a screenshot of how it is when windowed and when not windowed.
    Lately I barely have time to create maps for testing of UI changed (RL stuff keeping me from it). So any additional info about the problem that can be posted here can help me help you fix the problem faster :)

    Posted in: UI Development
  • 0

    posted a message on [Solved] Anchor to top? (different in windowed mode)

    @Hookah604: Go

    have you tried resetting the right anchor?
    <anchor side='right' relative='$this' pos='max' offset='0'/>

    or otherwise the screen resolution might be different, (like 16x10 vs 16x9) orso

    Posted in: UI Development
  • 0

    posted a message on My custom cursors keep crashing

    @Blazart: Go

    try preloading the image using the preload trigger functionality

    Posted in: UI Development
  • 0

    posted a message on Resource and food ui gone (Solved)

    @MiketheSspike: Go

    did you change anything for the race settings at the data editor? there is an option there which determines which resources are displayed at the resourcepanel.

    Also do you have the Hide Supply Panel action or so in use?

    Posted in: UI Development
  • To post a comment, please or register a new account.