• 0

    posted a message on Faction Wars ModX - Need Feedback

    [Update]

     

    Do note that graphics setting should be set to medium at least to play this mod, because low graphic settings will not render the top bar abilities and its animation. And many thanks to DrSuperEvil  for shedding some light on UI customization.

     

    Another issue is that switching (for example, player 1 when switched to the player 2 or player 3 spot in a lobby) or swapping places in a lobby will probably create some bugs (additional hero or unit created) due to the player settings in triggers.

    Otherwise, the game works fine and flawlessly.

     

    Feel free to check it out.

    Posted in: Map Feedback
  • 0

    posted a message on How to use triggers to Rescue one particular unit

     

    Quote from JeSuisUnEspion >>

    however the upgrade can be researched multiple times at once (it only works once),

     I don't get this, what do you mean by the upgrade can be researched multiple times (unless you have multiple upgrades on the same button, is this what you are trying to imply?)
    Maybe try looking into the weapon upgrades or armor upgrades in the Terran Armory (whereby weapon upgrades level 1, 2 and 3 for example, were on the same command button.)
     
    Posted in: Triggers
  • 0

    posted a message on How to use triggers to Rescue one particular unit

    Update:

     

    I have updated the demo map to include the condition whereby once the marine enters the region, the zealot will automatically follow the marine everywhere it goes to or moves. I think this suites the idea of a rescue system. The demo map updated as attached above.

    Posted in: Triggers
  • 0

    posted a message on How to use triggers to Rescue one particular unit

    In reply to JeSuisUnEspion:

     In many instances, reference to a specific unit usually refers to the triggering unit of the said Trigger Event.
    For example, assuming that you have a region as Region001, and you want it as such when say, a marine enters the said region (Region001), the neutral zealot will be converted/given to the player. You might need the following trigger :-
    Event: Any Unit Enters Region (Region001)
    Local Variable: Player = Owner of Triggering Unit <Integer>
    Condition: (Unit Type Of (Triggering Unit)) = Marine
    Action: Change Ownership of Zealot [127.85, 129.63 - The X & Y Point of the Zealot as placed in the map] to player Player and change color.
    You can refer to the attached demo map for further clarification. Thanks.
     
     
    Posted in: Triggers
  • 0

    posted a message on Count the number of a specify unit in a region

    This looks more like a trigger issue rather than a data issue, but anyway, let's create the following trigger:-

     

    Event - Any Unit Enters Region

     

    Local Variable              - Player = Owner of Triggering Unit <Integer>

    Global/Local Variable - Marine Group (Player) = Empty Unit Group (8) -> Array of players, say 8 players.

     

    Condition                      - (Unit Type of (Triggering Unit)) == Marine

     

    Action

    - Add Unit to Unit Group (Add Triggering Unit to Marine Group (Player)               

    - If then Else Conditions

           - Number of Units in Unit Group (Marine Group (Player)) = 60

                  - Then, do Actions,

     

                  - Else, do Actions.

     

    Is the above what you are looking for?

                

     

     

    Posted in: Triggers
  • 0

    posted a message on Document dependency error

    Wait, did you happen to add in standard dependencies such as Void/Swarm/Liberty dependency before adding in the Allied Commanders dependency as well as the Nova campaign dependency? 

     

    I think this might be the likely cause. You must add in standard dependencies before adding in other dependency such as the Allied Commanders dependency.

    Posted in: Melee Development
  • 0

    posted a message on Document dependency error

    Then it might be due to a corrupted cache file. You can try clearing the battle.net cache folder. The following link:

     

    https://us.battle.net/support/en/article/34721

     

    You might also want to run scan and repair on your Starcraft 2 files. The following link:

     

    https://us.battle.net/support/en/article/7655

     

    Let's see whether you might be able to add the dependencies after performing the above steps. Good luck.

    Posted in: Melee Development
  • 0

    posted a message on Document dependency error

    In reply to Sonemann75456:

     It has something to do with the dependencies not being loaded in my opinion. Did you receive an error at the start that states "Dependency Data could not be loaded?" This happens to locked dependencies and at times even with Blizzard dependencies.
    What you can best do is to close the editor and then reopen the editor, making sure you have added the dependencies, then wait till all the dependencies data have been loaded before you attempt to make any changes to your mod.
    And one more thing you need to know is that you need to own/purchase Wings of Liberty at the very least to be able to publish your very own map or mod (I'am just assuming here that you only have the free version of Starcraft 2 which does not permit you to publish your map or mod).
     
    Posted in: Melee Development
  • 0

    posted a message on Negative XP multiplier buff prevents unit from leveling up

    What about instead of using a negative multiplier, you can add arithmetic (real) for your buff, then multiply by 0.9. This is because when you multiply an equation with a negative, then the whole equation will be negative. This is the principle of mathematics rather than being a bug itself.

    Posted in: Data
  • 0

    posted a message on Functions that are not working or bugged.

    In reply to onlyleviathan:

     No. Once you put in the Break action,  it will terminate the loop. I have overlooked this and thought it was a bug. Anyway, do you have any success in the Magazine Owner of Unit function? Can't really see it in the built-in functions by Blizzard though.
    Posted in: Triggers
  • 0

    posted a message on Moving Inventory Panels 00 and 01

    The following an attached demo map. You need triggers to create inventory dialogs, pick-up items, use items etc.

     

    FYI, I just picked someone else's demo map because I do not have the time to go through all the details. Do give credits to the owner of the map if used. Thanks.

    Posted in: UI Development
  • 0

    posted a message on Moving Inventory Panels 00 and 01

    I assume that you attached the layout file as per the image? Otherwise, it will not work. 

     

    Aside from that, do you receive any error message?

     

    In regard to a demo map, I haven't tried it yet. But since I only received a message that it was attempting to add a desc with the same name of an already existing child, I assume that it works. Anyhow, I will try to attach a demo map probably by tomorrow to set up demo units, inventory units and triggers, etc.

    Posted in: UI Development
  • 0

    posted a message on Moving Inventory Panels 00 and 01

    Edited, can't create an Inventory Panel because they are Blizzard Only but however, you can move them around. Just go to the Game UI Data and in the Custom Layout Files section, add the layout file with the description as shown in the above. Hope this helps.

    Posted in: UI Development
  • 0

    posted a message on Moving Inventory Panels 00 and 01

    You can mess around with the frame anchors where in the example below, I set the anchor side to Top offset by -40 and Right in the Mid (Middle) position.

     

    First, create a new layout in the UI Editor, name it and add the below (Example only):

     

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <Desc>
         <Frame type="Frame" name="GameUI/UIContainer/ConsoleUIContainer" file="GameUI">

              <Frame type="InventoryPanel" name="InventoryPanel">
                   <Anchor side="Top" relative="$parent" pos="Max" offset="-40"/>
                   <Anchor side="Right" relative="$parent" pos="Mid" offset="0"/>
              </Frame>
              <Frame type="InventoryContainer" name="ContainerPanel00">
                   <Anchor side="Top" relative="$parent" pos="Max" offset="-40"/>
                   <Anchor side="Right" relative="$parent" pos="Mid" offset="0"/>
              </Frame>
              <Frame type="InventoryContainer" name="ContainerPanel01">
                   <Anchor side="Top" relative="$parent" pos="Max" offset="-40"/>
                   <Anchor side="Right" relative="$parent" pos="Mid" offset="0"/>
              </Frame>
              <Frame type="InventoryContainer" name="InventoryButtons">
                   <AcceptsMouse val="true"/>
                   <Anchor side="Top" relative="$parent" pos="Max" offset="-60"/>
                   <Anchor side="Right" relative="$parent" pos="Mid" offset="0"/>

                   <Frame type="CommandButton" name="Button05">
                        <Anchor side="Top" relative="$parent" pos="Max" offset="0"/>
                        <Anchor side="Right" relative="$parent" pos="Mid" offset="#InventoryButtonGap"/>
                   </Frame>
                   <Frame type="CommandButton" name="Button04">
                        <Anchor side="Top" relative="$parent/Button05" pos="Max" offset="0"/>
                        <Anchor side="Right" relative="$parent/Button05" pos="Min" offset="#InventoryButtonGap"/>
                   </Frame>
                   <Frame type="CommandButton" name="Button03">
                        <Anchor side="Top" relative="$parent/Button04" pos="Max" offset="0"/>
                        <Anchor side="Right" relative="$parent/Button04" pos="Min" offset="#InventoryButtonGap"/>
                   </Frame>
                   <Frame type="CommandButton" name="Button02">
                        <Anchor side="Top" relative="$parent/Button03" pos="Max" offset="0"/>
                        <Anchor side="Right" relative="$parent/Button03" pos="Min" offset="#InventoryButtonGap"/>
                   </Frame>
                   <Frame type="CommandButton" name="Button01">
                        <Anchor side="Top" relative="$parent/Button02" pos="Max" offset="0"/>
                        <Anchor side="Right" relative="$parent/Button02" pos="Min" offset="#InventoryButtonGap"/>
                   </Frame>
                   <Frame type="CommandButton" name="Button00">
                        <Anchor side="Top" relative="$parent/Button01" pos="Max" offset="0"/>
                        <Anchor side="Right" relative="$parent/Button01" pos="Min" offset="#InventoryButtonGap"/>
                   </Frame>
                   <Frame type="Frame" name="ContainerSizeFrame">
                        <Anchor side="Top" relative="$parent/Button00" pos="Min" offset="0"/>
                        <Anchor side="Right" relative="$parent/Button05" pos="Max" offset="0"/>
                   </Frame>
              </Frame>

              <!-- This should be last so it always renders on top of all other inventory frames. -->
              <Frame type="Image" name="Cursor">
                   <Anchor side="Top" relative="$parent" pos="Min" offset="0"/>
                   <Anchor side="Left" relative="$parent" pos="Min" offset="0"/>
                   <Width val="32"/>
                   <Height val="32"/>
                   <RenderPriority val="1024"/>

                   <LayerCount val="2"/>
                   <TextureType val="Normal" layer="0"/>
                   <Texture val="@@UI/ButtonBorderNormal" layer="0"/>

                   <TextureType val="Normal" layer="1"/>
              </Frame>
         </Frame>
    </Desc>

     

    Then, go to the Game UI Data in the Editor and in the Custom Layout Files section, add the new layout file. 

     

    Posted in: UI Development
  • 0

    posted a message on Moving Inventory Panels 00 and 01

    Hookup Panel "UIContainer/ConsoleUIContainer/InventoryPanel/ContainerPanel00" to the Game ui

     

    Nothing wrong with the format but because the Game UI is standard and with it the dialog frame sizes. When you try to position say a frame out from the standard ui, that is out of the bounds of the frame dialog, and because the dialog size is fixed, you will get the said error:- 

     

    I think the error i got said that the frame couldnt be loaded out of the path i entered.

     

    You can try the example that I gave you in the above, by creating a new dialog and with it the frame panel and see if it works. If the issue still persists, perhaps you can attach a picture of your triggers to see what went wrong. 

    Posted in: UI Development
  • To post a comment, please or register a new account.