• 0

    posted a message on Need help with custom UI

    there are people alive here :p

    so what is the problem you're having with the UI?

    Posted in: UI Development
  • 0

    posted a message on Can a Trigger Press/Click A key on Event?

    explain how you want to use it perhaps the effect can be achieved, just not the way you describe it though.

    Posted in: UI Development
  • 0

    posted a message on How do I make a Dialog box appear ontop of the menu buttons

    Seeing as the location change of the menu is your actual problem, wouldn't moving the menu items back to their old location fix your problem?

    Posted in: UI Development
  • 0

    posted a message on little FAQ for Patch 2.0.4

    @Ahli: not mentioned on the link you have there:
    You can hide the error display by using the following trigger:
    Event - Timer - Elapsed time is 0.1 Game Time seconds
    Action - UI - Hide Error Display Panel for (All players)

    this trigger does not work when using map initialization as event.

    Posted in: UI Development
  • 0

    posted a message on 12 slot inventory as "Help needed"

    @GodSpear: Go

    what do you exactly mean, 12 slot button???

    Also your image isn't working....

    Posted in: UI Development
  • 0

    posted a message on How do i edit positions of UI Console Boxes?
    Quote from Project_06: Go

    i guess i might have to get some one to do it, because i cant find a blank txt file that have EVERYTHING on inventory buttons, if i found that then im sure i could do it myself but ive searched around and cant find anything on all of the inventory/container positions.

    you mean something like this list or?

    Posted in: UI Development
  • 0

    posted a message on Change position of cost resources

    Have you tried adjusting one of these?

    These are the commandtooltip, and the resource label references.

    <Frame type='CommandTooltip' name='GameUI/UIContainer/ConsoleUIContainer/CommandPanel/CommandTooltip' file='GameUI'>
      <Frame type='Label' name='ResourceLabel'>
      </Frame>
    </Frame>
    
    Posted in: UI Development
  • 0

    posted a message on Detach Replay Panel from the Observer Panel

    @rtschutter: Go

    if the one is inside the other then you can use a $parent/$parent reference to unlink them, otherwise you can just set it's anchors so that they aren't connected anymore.

    Posted in: UI Development
  • 0

    posted a message on Move item bar to top

    You can also reset the bottom anchor that way you don't need to make a difficult choice for determining which anchors to use and what values they need. You can just reset the other anchors and use the ones that you know of.

    <Frame type="InventoryContainer" name="InventoryButtons">
    	<Anchor side="Top" pos="Min" relative="$parent/$parent/$parent" offset="45"/>
    	<Anchor side="Left" relative="$parent" pos="Mid" offset="0"/>
    	<Anchor side="Right" relative="$parent" pos="Mid" offset="0"/>
            <!-- reset the bottom anchor so that it is not used -->
    	<Anchor side="Bottom" relative="$this" pos="Mid" offset="0"/>
    </Frame>
    

    Also make sure that the buttons are still within the area of it's parent. it might be that the button is outside the area thus making it unclickable.

    Posted in: UI Development
  • 0

    posted a message on ObjectivePanel frame cannot be found.
    Quote from bakonking: Go

    @Helral: Go

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <Desc>
        <Frame type="InventoryContainer" name="GameUI/UIContainer/ConsoleUIContainer/InventoryPanel/ContainerPanelTemplate" file="GameUI">
            <AcceptsMouse val="true"/>
            <CollapseLayout val="true"/>
            <Width val="800"/>
            <Height val="880"/>
        </Frame>
    </Desc>
    

    the specified name is incorrect:
    name="GameUI/UIContainer/ConsoleUIContainer/InventoryPanel/ContainerPanelTemplate"
    first of all the word template isn't used in actual frame names.

    the correct name for the First inventory page is:
    name="GameUI/UIContainer/ConsoleUIContainer/InventoryPanel/ContainerPanel00"

    end with 01 for 2nd, 02 for 3rd, etc.

    Posted in: UI Development
  • 0

    posted a message on ObjectivePanel frame cannot be found.

    @Projekton: Go

    Use for the file tag GameUI, and not Desc.
    and you cannot set values for Desc itself.

    Could you perhaps post yout XML file then we can better see what is wrong with it.

    Posted in: UI Development
  • 0

    posted a message on Custom UI without Triggers.

    Here is a list of the GUI tutorials. Some are a bit old, but the xml technique didn't change so the information listed in it is still useable. http://www.sc2mapster.com/forums/development/gui/21441-tutorials/?unread

    Concerning the Issue order ability, there are 3 versions:

    • Issue order targeting point,
    • Issue order targeting unit,
    • Issue order without a target.
    Posted in: UI Development
  • 0

    posted a message on [SOLVED][PUBLISHING] Getting It onto Arcade

    A few things concerning dependencies that must be correct:

    1. Each dependency used has a battle.net location set.
    2. Each dependency used has it's relevant version also uploaded.

    If you for example have uploaded the dependency, and then make a change in the dependency without re-uploading it. Next you create a map using that dependency it will not be able to find the correct version of the dependency on battle.net. Locally it will work because there you have the latest version of the dependency.

    Hope this helps.

    Posted in: Miscellaneous Development
  • 0

    posted a message on Happy sinterklaas everybody
    Quote from rikky333: Go

    happy sinterklaas (who celebrate it)

    For those who don't know it, it's the Dutch version of Santa Claus. (or better said Santa Claus is the american version of Sinterklaas)
    It's celebrated amongst others in the Netherlands, Belgium, some northern parts of France.

    wiki explanation for those who are interested in it

    Posted in: General Chat
  • 0

    posted a message on Wc3 Style Armor System

    @Gwypaas: Go

    have you read this thread?
    Warcraft 3 Armor System
    don't know if the suggestions mentioned in the replies still work.

    Posted in: General Chat
  • To post a comment, please or register a new account.