• 0

    posted a message on Modify Max Vital Over Time

    Limit of stacks about 250, if I remember right, but be sure 100 stacks will not lag. Even few different behaviours with 100+ stacks will not lag.

    Posted in: Data
  • 0

    posted a message on Kill Experience % bonus when killing specific units

    1. you can define exp amount provided for killing such unit in Unit field Combat: Kill Experience

    2. Behaviour Buff fields Xp multiplier, XP scaled and Xp unscaled also change field Combat: Kill Experience

     

    Posted in: Data
  • 0

    posted a message on Actor visibility

    hm, yeah, you should check if they are really enemyes)

    Posted in: Data
  • 0

    posted a message on Actor visibility

    Check flag Actor: Filter - "Enemy" to "Enabled", other set as Disabled

    Posted in: Data
  • 0

    posted a message on Problem with second ability launching tentacle missile[Solved]

    Solved... wanted to reduce amount of elements and not made GeneralAttack actor for ability, what causes visual glitches during missile return
    Very very thanks man)

    Posted in: Data
  • 0

    posted a message on Problem with second ability launching tentacle missile[Solved]

    Still not solved

    what events response for:
    1. returning tentacle to Stand animation(clearing some sort of Attack animations?)
    2. Disattaching it from point of target(tentacle after executing ability stays at point of its attack.)

    Posted in: Data
  • 0

    posted a message on Problem with second ability launching tentacle missile[Solved]

    Yes, basically its copy of weapon, difference is second attack is ability not weapon.

    All works properly, simple visual glitch. If tentacle perform regular attack then its back to nornal unattached state.

     

    Something wrong with ability actor tentacle missile. I set copied effects properly in fields, however seems I trying refer to TentacleAttack instead AbilityEvent, or should I use Persistent before Launch missile?

     

    I even copied missile unit however this didnt helped

     
    Posted in: Data
  • 0

    posted a message on Problem with second ability launching tentacle missile[Solved]

    I have a unit which auto attacks with its tentacle correctly via ability ATTACK and used weapon(model used is LeviathanTentacle)
    however, once I add  another ability like say...SMASH ATTACK, which used separate missile, tentacle missile actor, LM and damage effects and etc.. and NO USE weapon...

     

    ...then my tentacle refuse to execute return during attacking with 2nd ability.
    Regular attacks looks fine, but how combine at one unit 2 different abilities of attack with same tentacle?

     

    how it solve?

    Posted in: Data
  • 0

    posted a message on Its possible launch tentacle missile in nowhere?

    Ok then I can create dummy unit which will be as attach point?

    Posted in: Data
  • 0

    posted a message on Its possible launch tentacle missile in nowhere?

    I need a animation how tentacle launch, reach certain point(for example its y-5 relative to unit face) and return.
    However I cant do it properly when launch missile using target point. I need do animation like tentacle attack when instant ability casts.

    Posted in: Data
  • 0

    posted a message on Animation disappear if near edge of screen

    Thanks for a help

    Posted in: Data
  • 0

    posted a message on Animation disappear if near edge of screen

    Subj, I have a flying unit (asteroid)moving across the map.

     

    Unit plays one shot type of animation periodically to immitate trail.

    Tho, when he near border of screen trail disappear immediatly, and if I focus screen on the unit in center when animation death plays normally.

     

    Actor of trail have only flag PlayContentOnce, other BSD messages are by default.

    I picked another model and its

    Someone faced it? how fix this?

     

    Posted in: Data
  • 0

    posted a message on When hero swap weapons old icon stays[Solved by myself]

    Seems very important give W1 with item, not via behaviour which also granted when equipping item, or Weapon 2 never shows, even if it used, instead you see disabled weapon 1 in hero icon. Solved.

    Posted in: Data
  • 0.978723404255319

    posted a message on [Finally Solved] Hows does one create the construction sequence for structures? How does one link model type actors to units?

    For morphing from gateway Warp gate use Actor event:

    Unit Construction.your unit.Finished

    Validate Unit: Is (your unit)

    AnimPlay Morph Morph, End and set Blend in 0.0

    Posted in: Data
  • 0

    posted a message on When hero swap weapons old icon stays[Solved by myself]

    I made item which have behaviour B1, this behaviour enable weapon W1 for hero.

    you can add another behaviour B2 via ability unit has.

    B2 gain unit another weapon W2, enable it and disable W1.

     

    all works fine, and I had 2 such items

     

    and one works perfect, another one during switch weapons from W1 to W2 always show one certain weapon B1 in UI and "disabled" when hero really used W2

    Problem that when I pick up one item both weapon's icons on hero swaps normally, when I pick another one(which is copy of first one) icon of hero weapon W1 always shown. Even when I removed this weapon by trigger during event "add B2" - hero use and fire with W2 but weapon icon will disappear at all like it no weapon

    Weapons havent flag "hidden" at both items, items are almost identical except effect trees, but copy seems glitched

    Anyone faced such before?

    Posted in: Data
  • To post a comment, please or register a new account.