SC2Mapster Forums

Development > Triggers

Timer in HOTS

  • 5 posts
    #1 May 18, 2013 at 14:33 UTC - 0 likes


    my problem belongs to a bug (?) I recognised earlier and posted here.

    Whenever I have the Swarm Story dependencies in my map, timers work quite odd. I cant change the style of the timer window (horizontal, vertical) and also new created timers show no time

    I used them like this: Timertest

    Its not a specific problem of my map - i tested it on an absolute blank map with Swarm Story and Liberty Story dependencies - same issues. Any ideas? I'm getting mad at this

    Last edited May 18, 2013 by Freddy2287


    #2 May 20, 2013 at 04:10 UTC - 0 likes

    @Freddy2287: Go

    It's probably because you use both those dependencies, swarm contains liberty, just use swarm.

    Still alive and kicking, just busy.
    My guide to the trigger editor (still a work in progress)

    #3 May 21, 2013 at 17:42 UTC - 0 likes

    Just tried it with a total blank map and only Swarm Story dependencies. Same issues. (image attached!)

    The given code leads to this crappy timer windows. The timer doesnt even start. It seams I'm missing something important!? ^^

    Last edited May 21, 2013 by Freddy2287
    • secondtry.PNG
    #4 May 21, 2013 at 18:07 UTC - 1 like

    I figured it out after extensive testing. You have to use a wait function after creating the timer that will go the length of the timer. For some reason the trigger is automatically culled when it runs out of other actions. This means that you have to extend it's life with a wait function.

    #5 May 21, 2013 at 18:42 UTC - 0 likes

    Whoa this worked. Thanks a lot! Have no one else experienced this strange behaviour this far? I used a "wait for timer XX to have 0 sec remaining". Works, so that the timer does start now. But what a strange behaviour.

    But there are still issues with the visual apperance. Timer Window borders are completely out of place/wrong size (as seen in the last screenshot). And also the commandos for changing the timer style (horizontal/vertical time/title) have no effect. Changing the timer from displaying remaining to elapsed time worked though.. even in the style command. Confusing.

  • 5 posts

You must login to post a comment. Don't have an account? Register to get one!