SC2Mapster Forums

Development > Galaxy Editor Bugs and Feedback

"add" palette missing for units and doodads

  • 19 posts
    #1 Dec 12, 2012 at 20:50 UTC - 0 likes

    My unit palette only shows the units present on the map .. so am i just missing a simple "view" setting or what

    my mac hates blizz

    i'm looking for a console command that would f u cken reload said unit palette

    or any other help that would allow me to continue perverting this fine toy with all the tools available

    any help is guaranteed a virtual cookie in return

    :)

    #2 Dec 13, 2012 at 18:55 UTC - 0 likes

    23 and counting

    Last edited Dec 15, 2012 by houndofbaskerville: edit: 35
    #3 Dec 16, 2012 at 11:06 UTC - 0 likes

    OuiN OuiN .. no one to save me.. not even a "better reinstall" or "wtf did you do? .. good luck"

    me sad panda

    Last edited Dec 16, 2012 by houndofbaskerville: aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
    #4 Dec 16, 2012 at 23:08 UTC - 0 likes

    real .. sadddddddddddddddd panda

    #5 Dec 23, 2012 at 19:05 UTC - 0 likes

    Try toggling the options in the View -> Show UI menu. You can turn off the list of existing objects with the Show Palette Existing Objects option.

    #6 Dec 26, 2012 at 12:36 UTC - 0 likes

    Yes thank you.. but that's what seems to be "broken".. i keep trying and it bugs... ouinouin fu ck gonna have to reinstall aaaaaaaaaaaaa

    ty for your help

    #7 Dec 27, 2012 at 00:39 UTC - 0 likes

    Since I've never used a mac, I have no idea how things work on it, but in Windows, there are 2 things the editor uses:
    - EditorVariables.txt in your operating system's profile folder
    - registry entries for editor things

    Maybe it's possible to "fix" your problem by deleting the variables text document or deleting (make backup before) of the editor's registry changes.

    Uninstalling something doesn't always delete everything created by a program.

    #8 Dec 27, 2012 at 12:04 UTC - 0 likes

    thank you, yes .. "doesn't always delete everything created" .. thats why i'm weary of reinstaling

    you right, i'll try the sweeping before the great reboot (i mean, i'll try them ALL one by one .. )^,; )

    thank you for your time

    #9 Dec 30, 2012 at 17:06 UTC - 0 likes

    tried swooping once more and got zilch nada fuc k all nothing

    still no unit palette .. just stuck on "existing units palette

    #10 Dec 30, 2012 at 18:37 UTC - 0 likes

    Does the doodad palette work?

    #11 Dec 30, 2012 at 20:28 UTC - 0 likes

    yes...

    which is sort of why i don't get it

    Last edited Dec 30, 2012 by houndofbaskerville
    #12 Dec 31, 2012 at 13:12 UTC - 0 likes

    i am a sad panda... my bug will carry into 13 ..

    but at least someone dedicated 5 minutes to my work around

    :) says something about mapmakers helping other mapmaker...

    Last edited Dec 31, 2012 by houndofbaskerville: black to white .. ty ty ty ty ty maticpl for helping me
    #13 Jan 01, 2013 at 16:33 UTC - 0 likes

    aaaaaaaaaaaaaaaaaaaaaaaaaaahahahahahahahahhaa..

    now the doodad palette too... aaaaaaaaaaaaaaaaaaaaaaaaaaaa

    ps: Dragoneles jinxzd it

    aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

    #14 Jan 01, 2013 at 22:52 UTC - 0 likes

    Even after reinstall of the game ... no palette for units or doodads .. just the "present on the map" palette ............

    i am at a loss

    (generaly crying throughout this typing) .. i'll just buy the next .. hope mac gets it before next year... ?!?!?

    have fun.. without me

    Last edited Jan 01, 2013 by houndofbaskerville: aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
    #15 Jan 08, 2013 at 00:54 UTC - 0 likes

    funny how people get attached to things

    i liked drawing maps ...

    not enough to get on a windows but still...

    mmm might do that instead... sad huggy bear really

    #16 Jan 08, 2013 at 03:29 UTC - 0 likes

    @houndofbaskerville: Go

    I came here to post the exact same problem.

    I'm thinking that there was a recently added patch that broke this functionality.

    Keep in mind, Galaxy Editor updates every time we open it.

    How do we go about reporting bugs to the big heads?

    #17 Jan 08, 2013 at 21:10 UTC - 0 likes

    Well i got a ticket from blizz that got me a link to battle net forums ...

    i sincerely hope you can get mapster users' help (where/when i couldn't..) mac users don't really seem to get too much attention .. and for blizz the editor is ..mmm (clearing throat not to vo.it) .. secondary.

    glhf (good luck .. have faith)

    YES.. reporting it to blizz on their "support contact" (getting a ticket going (with all your info/screenshot if required and error logs etc.. all that you can do really), then resending it as unresolved with a message ...) is "good" .. it gets to show them the bug (whether anyone invests in resolving the issue remains to be seen)

    then posting on forum ... then praying

    i must be too old but i haven't got the will to do more than message blizz and surf (to see how the last posted mac users where treated/helped/issues were resolved/ignored whatever).. i get angry and disheartened when my hopes get up and get squashed and i know it.

    i'm sad .. have to get an old pc back into shape or wait for Hots editor (more and more the "out with the old and force in the new" is getting to me.. sorry, but i miss my editor, it s been 2/3 weeks without units and 1/2 without doodads ... :( :( :( :( :(

    ps: again sorry.. but like i told blizz: "i better hope every mac user gets it" .. or we both can bin our galaxy (i still remember how much good it did to cry out in the night for staredit)...

    pps: i don't remember if i tested the editor directly after i reinstalled (before updating by logging in) ... (plus i might have missed something when clearing the sc files) .. still that would be a s hitty work around.

    ppss: im on 10 6 8

    Last edited Jan 08, 2013 by houndofbaskerville: added ppss s
    #18 Feb 14, 2013 at 10:49 UTC - 0 likes

    bou hou hou i want lighting doodads... bouhou hou... blizz hates macs ... bou hou .. can't add.. bou hou ... don't want to ask mapmakers for another help (map filled with all doodads i'd like to get .. bou hou :-)

    #19 Jun 28, 2013 at 20:36 UTC - 0 likes

    Did anyone ever find a solution to this issue? Just opened the editor to find this issue too.

    Very much the same as you reported. No unit pallete. All other palletes work fine, but I'm unable to place new units :P

    Last edited Jun 28, 2013 by Cloud_Wolf

    http://www.engamer.net/assets/images/banner/01.jpg http://www.engamer.net/assets/images/banner/add.jpg

  • 19 posts

You must login to post a comment. Don't have an account? Register to get one!