SC2Mapster Forums

Development > Galaxy Editor Bugs and Feedback

"lighting status: out of date"?

  • 4 posts
    #1 Nov 12, 2012 at 08:25 UTC - 0 likes

    So my map (I'm trying to update the "Empire Builder" map originally by Anteep) has a near pitch-black terrain. When I changed it to a different tile-set the terrain issue went away, but when I went to "Map Status" it has this curious error message at the bottom.

    lighting status: out of date

    With the "out of date" in red. Anyone know what that means? A quick google search turned up nothing...

    MLP: Spike http://imgur.com/a/hKHq7#10

    #2 Nov 12, 2012 at 09:21 UTC - 0 likes

    I would guess that you need to re-generate map lighting.

    When I want your opinion...I'll give it to you!

    http://i.imgur.com/8iyk6Lw.png?1

    #3 Nov 20, 2012 at 13:25 UTC - 0 likes

    I think it has to do with the option to "Generate Static Shadows" located in the Data main menu (Terrain window > Data > Generate Static Shadows... shortcut: Ctrl+Shift+L)... I have this message very often but it's not a big deal, and I think that's how I fixed it. The message appears when you publish the map as well I think, though it won't prevent you from uploading it anyway. Sometimes it causes surprisingly weird glitches (messed up terrain lighting while ingame, probably because you modified the terrain after generating shadows)... Usually, generating shadows again fixes the problem.

    Last edited Nov 20, 2012 by ZealNaga
    #4 Nov 24, 2012 at 05:42 UTC - 0 likes

    @ZealNaga: Go

    Thank you for your through reply. That makes much more sense

  • 4 posts

You must login to post a comment. Don't have an account? Register to get one!