SC2Mapster Forums

Development > Artist Tavern

Model Question: Mdx to M3

    #1 Jan 05, 2012 at 02:08 UTC - 0 likes

    I have a few models that are currently in the Warcraft 3 (.mdx) format, and I would like to convert them into a .m3 model. They were originally WoW models so their quality is better than Warcraft 3 and they have custom animations and team color already added.

    Is it possible to convert these while retaining the animations and team color? Any help is appreciated!

    #2 Jan 05, 2012 at 04:53 UTC - 0 likes

    @Terminator8: Go

    Yes is it possible and relatively simple. the current version of NiNtoxicated's M3 plugin pack contains a MDX import/export plugin that can automaticly convert .mdx to .m3 http://www.sc2mapster.com/assets/m3-export-plugin-3ds-max/

    There is also a tutorial on how to convert WoW models without 3DSmax http://www.sc2mapster.com/forums/resources/tutorials/8299-galaxy-noobs-wow-to-sc2-in-30-seconds-no-3dmax/

    #3 Jan 05, 2012 at 23:23 UTC - 0 likes
    Quote from kinkycactus: Go

    @Terminator8: Go

    Yes is it possible and relatively simple. the current version of NiNtoxicated's M3 plugin pack contains a MDX import/export plugin that can automaticly convert .mdx to .m3 http://www.sc2mapster.com/assets/m3-export-plugin-3ds-max/

    There is also a tutorial on how to convert WoW models without 3DSmax http://www.sc2mapster.com/forums/resources/tutorials/8299-galaxy-noobs-wow-to-sc2-in-30-seconds-no-3dmax/

    the problem is, when I import the .mdx model into 3ds, none of the textures seem to apply to the model.

    #4 Jan 07, 2012 at 03:58 UTC - 0 likes

    @Terminator8: Go

    In NiNtoxicated's release notes for the MDX (http://www.sc2mapster.com/forums/resources/third-party-tools/4237-updated-mdx-importer-for-3ds-max/) He states that the plugin does not import the textures due to glitches and different formats.

    The Models do retain their UV maps so you can add them as a Starcraft 2 Material.

    to do this: -First, the .MDX uses a different texture type called .BLP. You will need to convert these to .DDS. you can find a .BLP converter on the curse.com main site (http://www.curse.com/addons/wow/blpc). It has the option to Save As different file tyes. I recommend .TIFF as it retains alpha channel information, BMP and JPEG does not.

    -Open up the Texture TIFF in Photoshop, you will need the Nvidia .DDS plugin (http://developer.nvidia.com/nvidia-texture-tools-adobe-photoshop) and save it using DXT3 Explicit Alpha.

    - In 3DSmax open up the Materials Window ( Hotkey M ) Select a Blank Material. In the Material Type, Change the type from Standard ( click standard ) to Starcraft 2. Under the Layers Tab of the Starcraft 2 Material, you will see all the layer slots avaible. click the "none" button next to Diffuse and choose 3DXmax Bitmap. You will then have the option to select and assign your texture.

    Now Select your Entire Mesh and in the Materials window, In the Top Menu, Select Material > Assign to Selection.

    Your texture should be applied and now be able to see your texture in the Renderer (F9)

    If your model contains Multiple components with seperate maps, you will have to create Material Sets and assign them to the objects manually (click and drag material to desired object)

    • step1.jpg
    • step2.jpg
    • step3.jpg
    • step4.jpg
    #5 Jan 07, 2012 at 21:29 UTC - 0 likes

    @kinkycactus: Go

    You are amazing. Thank you! I will try that now.

    #6 Mar 27, 2012 at 04:17 UTC - 0 likes

    I actually tried to convert .mdx models into .m3 using gmax (Free 3ds max) but I always get a "FileIn Exception" error when I try to run NiNtoxicated's .m3 scripts...

    #7 Mar 27, 2012 at 05:34 UTC - 0 likes

    @RanchBurner: Go

    You can get a free student version of 3DS Max through Autodesks website https://students.autodesk.com/
    I recommend Max 2011, max 2012 seems to have issues with the scripts.

    #8 Mar 29, 2012 at 22:14 UTC - 0 likes

    So I can't convert with gmax? I'm no college student either.

    Last edited Mar 29, 2012 by RanchBurner
    #9 Mar 30, 2012 at 07:02 UTC - 0 likes

    @RanchBurner: Go

    Most likely not. Gmax development was discontinued several years ago, and I believe the .M3 scripts were written in Max 2010. Any Syntax changes or updates made would not translate well backwards. This will probably be the case with Blizzard's StarTools as well.

    You can sign up for Autodesks student program with the name of your high school or a local Jr. college.
    A 30-Day Trial is also available.

    #10 Mar 30, 2012 at 14:06 UTC - 0 likes

    @kinkycactus: Go

    Basically AutoDesk are rubbish. Max2009 is by far the best, most stable and fastest version available. Each new version has trouble reading scripts made for previous versions, due to legacy features being scrubbed and optimisations being made. But, for the developers of said scripts, it generally a case of just recompiling.

    @RanchBurner - I have a full version of max. If you would like I can convert these models for you, let me know.

    #11 Mar 30, 2012 at 18:09 UTC - 0 likes

    @Nardival: Go

    I wouldn't say that, it's just that autodesk feels, like most companies, that they HAVE TO release a new version of their programs accordingly to the year instead of making a huge version with actual real updates. From 2009 (Max 9) to 2012, really, there hasn't been much and IMO I'd have made only one new release for the past 3 years. But I'm not a huge conglomerate so they probably know what they're doing with regards to making money.

    But I do find some of the newer features quite fascinating, the material editor for example, which you can now easily make bump/normals/spec/whatever maps you want with just a diffuse. Still not as good as making a real high poly model and baking the maps but much better/time saving and easier than doing them in an image editor.

    But yeah, scripts don't work on gmax, nor they do on versions previous to 2009 and there is allegedly incompatibilities with 2012. I use it just fine on 2011, but right now I'm in the process of buying MAX 2013 so I'll get back on this topic when I see my results with the plug in in that version.

    Last edited Mar 30, 2012 by xcorbo

    I AM MAPSTER'S OFFICIAL BANNER. FEAR ME.

    #12 Apr 06, 2012 at 18:16 UTC - 0 likes

    @kinkycactus: Good to know these facts, I'll just wait for StarTools. Don't worry, I got other good things in my life. :)

    @Nardival: Sounds good! I'm not really in a hurry these days but thanks for offering. :)

    #13 Apr 11, 2012 at 06:44 UTC - 0 likes

    star tools were originaly designed for max 2008. As as i know compiled (not maxscripts) plugins of max 2008 aren't compatible with max 2009 and onward. The same happened with Wc3 Art tools, they were designed for max 4.2 but only ran on max 4 and max 5. The reason has to do that max uses microsoft's visual studio API for their plugins so if they update to a newer version of visual studio, the new 3dsmax version turns incomptable with the old plugins.

    Last edited Apr 11, 2012 by BlinkHawk
    #14 Mar 13, 2014 at 05:31 UTC - 0 likes
    Quote from kinkycactus: Go

    @Terminator8: Go

    In NiNtoxicated's release notes for the MDX (http://www.sc2mapster.com/forums/resources/third-party-tools/4237-updated-mdx-importer-for-3ds-max/) He states that the plugin does not import the textures due to glitches and different formats.

    The Models do retain their UV maps so you can add them as a Starcraft 2 Material.

    to do this: -First, the .MDX uses a different texture type called .BLP. You will need to convert these to .DDS. you can find a .BLP converter on the curse.com main site (http://www.curse.com/addons/wow/blpc). It has the option to Save As different file tyes. I recommend .TIFF as it retains alpha channel information, BMP and JPEG does not.

    -Open up the Texture TIFF in Photoshop, you will need the Nvidia .DDS plugin (http://developer.nvidia.com/nvidia-texture-tools-adobe-photoshop) and save it using DXT3 Explicit Alpha.

    - In 3DSmax open up the Materials Window ( Hotkey M ) Select a Blank Material. In the Material Type, Change the type from Standard ( click standard ) to Starcraft 2. Under the Layers Tab of the Starcraft 2 Material, you will see all the layer slots avaible. click the "none" button next to Diffuse and choose 3DXmax Bitmap. You will then have the option to select and assign your texture.

    Now Select your Entire Mesh and in the Materials window, In the Top Menu, Select Material > Assign to Selection.

    Your texture should be applied and now be able to see your texture in the Renderer (F9)

    If your model contains Multiple components with seperate maps, you will have to create Material Sets and assign them to the objects manually (click and drag material to desired object)

    Hi there I am having issues with two models I converted for warcraft 3 and I am trying to get them to work for starcraft 2 so i followed you instructions but i can't seem to get past to matierial part could you help me.

    the following link has the zip folder with the mdx and blp files in a folder called " Convenant ships" and the dds files are in a folder called "dds files for Covenant ships"

    http://www.mediafire.com/download/43bj0efep4ifjfe/Covenant+Ship.zip

    if you can figure out want i am not doing right or at all please let me know.

    Last edited Mar 13, 2014 by gps2
    #15 Mar 13, 2014 at 06:47 UTC - 0 likes

    @gps2: Go

    Hello, are you working with NiN's Plugins exclusively or are you using Blizzard's M3 Plugins?

    This walk through was originally made 2 years ago before Blizzard release their plugins.

    I've made a image tutorial that should hopefully help you out:
    If you are using Blizz's plugins go from image 1 to image 2.
    if you are using NiN's plugins, go from image 1 to image 3.

    once you create the material, click and drag the material onto the mesh.

    • Sc2MaterialAdd1.jpg
    • Sc2MaterialAdd2.jpg
    • Sc2MaterialAdd3.jpg
    #16 Mar 13, 2014 at 14:05 UTC - 0 likes

    I have the STarcraft 2 art tools Now I followed steps 1 and 2 but I keep ketting a all white texture like look when putting the miterial on the model do I need to layer it if so how do i do that??

    #17 Mar 13, 2014 at 20:33 UTC - 0 likes

    @gps2: Go

    Ooooohhhh, that's simple enough. The texture is applied correctly to the model, and would be correct in game, you just need to enable it in the viewport to make it visible in 3d max.

    - Open the Material Editor
    - In your material, scroll down and select the Diffuse Slot
    - Once you're in the Diffuse Slot Subsection, there is a small button that looks like a checkbox with a lightbulb
    called "show standard map in viewport" click this button and your map should appear on the model.

    • Note: Textures may not appear at full resolution in 3ds max, this is just something 3ds max does to keep framerate high.
      The texture will look fine in game (or at the res of the image file).
    • ShowInViewport.jpg
    #18 Mar 14, 2014 at 05:04 UTC - 0 likes

    ok so i did everything you said to do and this is the resault.

    would you be able to fix them up it seems that they are not getting the miterials propurly and i dont know what i could ditor after following your instructionsmap ebe doing wrong.

    here is the folder for the models on mediafire

    http://www.mediafire.com/download/ptpjwwndaf92qq9/Halo+SHips.zip and the screenshots from the map editor after following your instructions

    • Corvette.JPG
    • Cruiser.JPG
    • UNSC_Cruiser.JPG
    • UNSC_Frigate.JPG
    #19 Mar 15, 2014 at 01:09 UTC - 0 likes

    @gps2: Go

    In the M3 Exporter menu, make sure "Use Mopaq Paths" is checked, this should make sure its using the texture path in the editor and not local.
    I've attacked the model I exported as well as the max and map file. if you still having difficulties please upload a max file of one of the ships.

    Another Tip: always import the textures First, then Save, then import your model. if you import them at the same time the model will not be able to locate the textures and ill apear blank, if this happens simply save, close and reopen the map.

    Name Size MD5
    New_Export.rar 1.1 MiB ff95ed428787...
    • Mopaq.jpg
    • CorvetteImport.jpg
    #20 Mar 15, 2014 at 05:52 UTC - 0 likes

    ok I did what you said but they are still turning white i might be doing something wrong because i am new to using autodesk for starcraft 2 stuff ( use to do stuff for warcraft 3) but i did save them with auto desk and put the dds files in assets/textures in a zip folder on media fire.

    I do appoligies if this is a hassel by the way.

    http://www.mediafire.com/download/cnx1lcd87zht452/Models.zip

You must login to post a comment. Don't have an account? Register to get one!